/sys/devices/midi/initDevice changed in 2021 build

This took me a second to figure out, but it looks like between 2020 and 2021, the naming of /sys/devices/midi/initDevice changed for some reason from mixedCase to lowercase, so now references to it should be to /sys/devices/midi/initdevice.

This breaks some of my references, but it also breaks the built in method for refreshing MIDI devices from the Midi Mapper dialog, as the Check MIDI Devices button triggers /ui/dialogs/dialog_mapper/checkdevices/panelexec1, which still has the mixedCase reference.

My suggestion is to either change it back, or document the change in backwards compatibility and update the internal methods

Hey @drmbt, thanks for the report.

I can confirm that there is an issue and I added it to our bug tracker.



Thanks Michel. Any ideas as to whether that might go back to mixedCase, or if I should update my references to the new naming convention?

If should not have changed - this was not intentional so we’ll try to roll it back.

1 Like

2021.12360 is now posted with this fix.