TDAbleton - TouchDesigner Ableton Connection

fixed our connection issues by building a filter into the TDA.py to only send info and data from tracks with a specific prefix in the track name - this streamlines everything massively reduces the amount of data being sent and its all working together again

b

Sorry for slow reply. For some reason I haven’t been getting notifications on this thread!

Looking into all issues posted since last update.

@benflock if you can share your set that breaks it would be a great help. Don’t need audio data. Send to ivan@derivative.ca

Uploaded 1.15.0 to top of thread

  • Fixed bug with duplicate scene names only showing one scene
  • Added Cancel button to TDA Master warning dialog

Backwards compatibility warning: SongInfo[‘scenes’] is now a list instead of a dictionary indexed by name.

@benflock: the issue you reported is larger and will probably have to wait until TD 40k is released. I haven’t been able to duplicate the problem, but I plan on building in a Track filtering mechanism like the one you hacked into TDA.py…

Thanks everyone for the feedback!

Hey Ivan

thanks - sorry for slow reply - show opens tomorrow so will have time to upload the set for you to replicate later in the week

b

Not sure if this is a legit error or just ableton stupidity,

but if there’s a scene without a name, you get the error:

line 18, in onTableChange SystemError: error return without exception set

also, are you able to connect to another computer on the network running ableton? I thought i tested it before and was able to, but using 1.15.0 gives the error that i can’t connect.

Important - TD build 26450 has an issue that breaks TDAbleton. Will be fixed soon!

Bunch of bug fixes released in 1.15.1 (at top of thread). Thanks to everyone that has reported issues.

  • Max issue - Macro numbers are no longer mixed up
  • Max issue - deleting or adding tracks no longer breaks connection with TDA devices
  • Max issue - TDA Rack devices have accurate help on “OUT” buttons
  • Adding cue points no longer causes textport error spam
  • Empty scene names no longer cause errors

I’ve heard people are having some trouble connecting, possibly due to new default of OSC port 8001 instead of 8000. Make sure your tdAbleton component and TDA_Master Live device have matching settings. If at first you don’t connect, try a couple different ports. If you still have problems, do post here!

Hello! The information that arrives from Ableton to TD without problems. But not from TD to Ableton. For example, when trying to change the volume of a track. Any ideas?

What TD build are you using? 26450 has a problem that will be resolved in next release.

ok rolling back to 25850

i noticed an error in 1.15.1 though.

It’s on “chopexec_scrubWhenStopped” (Chop Execute) in the AbletonSong COMP. It’s points to an absolute reference, when it could just be a relative one (since the CHOP is references is right next to it). I noticed this because my top-level/parent container wasn’t named project1 and i got an error.

@why: yikes, thank you. Will be fixed in 1.15.2

Uploaded TDAbleton 1.16.0

  • Fixes bad reference in chopexec_scrubWhenStopped
  • abletonSong now has song Loop Start and Loop Length controls/watchers
  • abletonSong now has onLoopStartPassed callback

Anyone know of a good way to render non-realtime TDAbleton controlled content?
Say for example if I wanted to render a video from Touchdesigner with realtime turned off, which slows touchdesigner so it can render every frame, as opposed to skipping frames, and have that slow down the TDAbleton connection as well so the content syncs up properly.

In an ideal setup, I would like to send OSC messages to Ableton to advance to the next frame. OR have some kind of midi clock sync going on. Any ideas?

hi spaghetti -

Are you controlling Ableton with TouchDesigner or do you have controls from Ableton sending into TD?

I recently completed a music video where I had written a bunch of automation in Ableton that was controlling parts of my TD patch. The way I made the offline render was to do a play-through of the song with Realtime turned on in TD to capture all the automation into a Record CHOP. Then, when I was doing the non-realtime rendering, I looked up the channel values based on the current frame of the timeline.

Is that the pipeline you would need?

Ableton doesn’t have a concept of frames, so I’m not sure how “advancing the frame in Ableton” would work. You could advance the playhead position by the amount of time that would elapse in a frame if you were in realtime mode.

Posted 1.17.0 in top post.

  • Changed default OSC Ports again. There were problems on too many systems. Send feedback if you have conflicts
  • Better sorting of output channels from abletonMIDI, abletonLevel, and abletonRack components.
  • Default Note Channel options on abletonMIDI to show a range of note channels before actual notes are received
  • Fixed a bug in the Demo Set where the abletonRack was broken

this is awesome

Hello! sounds great
Any tutorial on this?

Hi Ivan,

Thank you so much for building this tool - it has been so fun to play with.

I am having an issue in consistently looping through ableton arrangement scenes

I am syncing a series of looks with TDAbleton. I reference a channel that counts up every time a TouchDesigner cycle completes, looping from 0-3. This count updates the ‘scene to fire’ string parameter, as well as the ‘fire clip’ boolean parameter, of the TDAbletonSong COMP.

Sometimes everything transitions perfectly. Other times, the same scene fires repeatedly. I find that if I have the network editor opened at the level of the TDAbleton COMP, the scene switching works as expected, but if i exit that view, the switching stops working.

Attaching my project below. Please refer to the ‘TDAbleton Song’ Comp and the ‘Show Control’ Comp inside of the project
_Spring_Fest_Beta.13.toe (219 KB)

^^Figured out my above issue - just wanted to post the fix here in case anyone else encounters a similar issue.

Touch is pull-based, so since the Null CHOP channel being referenced in the TDAbleton Song COMP was not being called for in perform mode, the Null CHOP was not cooking.

Going to the Common page of the referenced Null CHOP and switching cooking to ‘Always’ resolves the issue.

Thanks to everyone for their help and support solving this!

Posted 1.18.0 in top post.

[]All components now have selective cooking optional with par toggle (default is False)
[
]abletonSong now has current_cuepoint and tda_connected channels
[]abletonSong now has callbacks onTDAConnectionChange and onSongInfoChanged
[
]tdAbletonmaster comp now has output with connected channel
[*]fixed channel prefix stripping in MIDI, level, and rack components

Note: I am now only testing as far back as TD version 2018 26590. Should work as far back as 2017 10k versions, but that’s no longer guaranteed.