TeamViewer & Middle Mouse Slider broken

We tend to use TeamViewer quite a bit for our installations and shows. One thing that has always been a bit frustrating is that when we remote into a TD server and try to use the middle mouse slider on any parameter, TD tends to freak out and write very high values (like 10,000x what we meant to input) into the parameter field.

It would be super handy if this worked as expected. Has anyone else encountered this issue? Any workarounds other than just typing in values manually?


Since I use TD the valueladder has never worked for me when using teamviewer, or anydesk or any remote software. At least the values which come out are never what I intented, impossible to control, it thinks the mouse is in different location than it is.
it would be really really great if a solution could be found!

from what i recall this relates to the way touch intercepts the mouse input at the os level for doing middle mouse click drag, and how teamviewer breaks that relationship in the process of passing mouse between systems. it may be that the things that allow it to work in normal use are not possible with the way teamviewer passes data. if that’s the case, maybe introducing some kind of key binding to get the same functionality would be a solution?

Sorry for opening an old thread, but this using Mouse Buttons in Touch (in combination with TeamViewer) is still not working.

Any recommendations how to handle this situation?