TouchDesigner cooking while mac sleeps

TouchDesigner Build: 2023.11340
macOS: 14.2.1 (23C71)
chip: Apple M1

i’ve noticed that if i close the lid of my macbook when touchdesigner is cooking, it does not seem to fully go to sleep as it should. i will come back to the computer after some time and it will be very warm to the touch and drain my battery if i’m not plugged into a power source. perhaps this is an intended behavior or a setting i haven’t been able to find on my end. i think that the ideal default behavior would be for touchdesigner to stop cooking when i close the lid of my laptop. thank you!

Hey @jjaareet

Thanks for the report. This is odd.

This is logged to be looked into.

Best,
Michel

Hi @jjaareet - it would be helpful to get some more details around this -

  1. are you in perform mode or the network editor when you see this behaviour?
  2. does this happen with an empty project, or only some projects?

It’s possible something else is preventing the computer sleeping, and then when it wakes for whatever that is, TouchDesigner starts running again - or it’s possible something in TouchDesigner itself is preventing sleep. To gather some detail, it would be really helpful if you could do the following sometime when you don’t need to use your Macbook for a bit:

  1. disconnect all external devices and displays
  2. connect to power
  3. quit all applications including menu-bar apps like Dropbox, etc
  4. open the Terminal (in /Applications/Utilities)
  5. type pmset -g assertionslog and press return - you will see quite a lot of detail continue to be printed, leave this running
  6. open a second Terminal window (command-N)
  7. in the new window, type pmset -g uuidlog - you will see a few lines which will be updated if/when the system sleeps, leave this running
  8. open TouchDesigner and leave it running
  9. close your laptop and leave it closed for at least an hour
  10. open the laptop
  11. quit TouchDesigner
  12. press ctrl-c in the first Terminal window, copy all the text there and paste it here
  13. press ctrl-c in the second Terminal window, copy all the text there and paste it here

If you’d rather not post them here, you can send the logs to tom@derivative.ca.

Many thanks - Tom

Not to derail the bug finding, but my Mac does this with every app, since it wakes for any Bluetooth activity. I ended up using blueSnooze to turn off all Bluetooth when the Mac sleeps and it’s made a difference.

I can see that the Mac waking while touch is running would drain the battery pretty easily.

Bruce

Cheers @bwheaton - yep, TouchDesigner continues to run when the Mac wakes for background activity - usually for fairly brief periods. It’s still useful to get a more detailed picture in case something TouchDesigner is doing in this specific case is preventing the Mac from sleeping at all - which shouldn’t happen.