TouchDesigner crashes when "Open as Seperate Window" to a second monitor (bloatware)

No I did not and everything seems to work fine until now

1 Like

Hi, I confirm it’s the alienware command center. I installed it, the crash appeared, I uninstalled, the crash disappeared.

I am having the same issue. I uninstalled Alienware Command Center and will try again, but my preference would be to have both installed in the future. Let us know when this is resolved! Thanks for the help.

I am having the same issue. I tried uninstall alienware command center but still have the issue.

It also freeze if I try to open a pop up menu on a secondary monitor.
It seems to be a problem to create a window COMP on a secondary monitor added to another instance of TD.

If I try to create the window on monitor 0 and move to it to monitor 1, it works.
If I try to create the window on perform mode on monitor 1, it works.
If I try to create the windows on “separate window” on monitor 1, it freeze.

I tried disabling completely internal chipset and force to NVIDIA card but didn’t fix it. I try the contrary to force everything on the chipset but didn’t fix it either.

Alienware Laptop M15, W10, Nvidia 2060 (driver up to date)
Sorry, no dmp file to share

Curious, usually Command Center has been the issue.

This might not be possible for you to test for us, but if you can… what happens if you use 2 external monitors and close your laptop monitor (ie run in clamshell mode). Any way you can connect 2 external outputs (monitors or projectors, whatever). I am wondering if the problem goes away and it works with 2 monitors when the internal GPU is out of the mix, this does point to the issue still being going from internal GPU to external. Although its not a solution, it would help us understand the situation.

For now I can’t do that test. As soon as I get the necessary monitors, I’ll tell you !

Thanks !

Have a nice day, everyone.
I have the same problem, any project immediately crashes when opened on a second monitor.
I am using build 2020.44350 (but this problem was with all versions of this year)
My DELL G7 17 7790 laptop:
processor: Intel Core i7 9750H (2600 MHz)
video card: NVIDIA GeForce RTX 2070 Max-Q (8 GB)
Windows 10 Home
I am using the latest drivers for DeLL and Nvidia
I read above that it is possible to uninstall Alienware, but it didn’t help me.
If someone solved this problem differently, I will be glad to any feedback.
Thank you!

I had a similar symptom and it stopped happening after uninstalling the alienware command center.

Hi Ben,

I have been experiencing a similar issue of TouchDesigner crashing when right-click opening on operator any floating window (like Parameters, or View, etc) if the Network is on the extended monitor.

I did several tests:

  1. running Network on a laptop screen, opening floating parameter window on a laptop screen, then moving that floating window to extended monitor, things working fine, no crashes.
  2. opening file and moving Network window to extended monitor, then trying to open a floating parameter window of operator, TD freezes and shows white screen. It does not create a crash file.
  3. I followed your suggestion to run TD in clamshell mode with two extended monitors attached: TD moved my Network to one of my monitors, opening floating windows on that same extended monitor doesn’t freeze TD and it works fine.
    I tried to leave the Network on the initial extended monitor and move the floating parameter window to the other monitor, still works. But when I tried to move the actual network to another external monitor and try to right-click and open the floating parameter window, it goes white and is showing (Not Responding) and freezes.

My observation: TD freezes and doesn’t respond when after opening a file you try to migrate the Network window to another monitor, it doesn’t allow to open any extra windows. I had other application windows running simultaneously and it didn’t cause the issue. Only when I moved the main TD network window to another monitor, this issue started to appear.

I am using an ASUS ROG G703 PC laptop. (Intel Core i7-8750H CPU 2.20 GHz, NVIDIA GeForce RTX 2080) I followed the steps to remove any visible bloatware and disable apps on a start. I do see that there are a bunch of apps running in the background, including Armory Crate that I did not dare to remove, but no other apps besides TouchDesigner are running actively. I also made sure that my external monitor refresh rates are 60Hz. Right now, it is not an issue and I can totally work from my main laptop screen, but it would be great to know if there is a fix for this. Maybe my laptop is not set up properly, it could be also an issue on my end.

Thank you,


I wanted to update you on my issue.

I did re-install clean Windows without the manufacturer’s add ons and that fixed the TouchDesigner freeze issue. It must have been the bloatware and by stripping PC to just Windows has fixed it. I hope this is useful for people who will be experiencing similar issues.

Thank you,

Thanks for the feedback, appreciated!

FYI I had same problem today when trying to “Open as Separate Window” from Window COMP… uninstalled Alienware Command Center and problem solved. Thanks everyone for the detective work!

1 Like

I’ve found that disabling the Nahimic service fixes the issue without uninstalling Command Center

1 Like

I’m a asus desktop user, I removed all the sonic sound application and it works now. FYI

I had the same problem with my MSI laptop 3 years ago. Suppressing mainly Nahimic softwares but also daemons solved the problem.


Just here to add that uninstalling armory crate solved the issue on a rog build


Hello, Im running into these crashes while trying to close an extra pane. I dont have any bloatware on my Razerblade 15". I just read through this post and seems my crash is related to this topic… My Drivers are up to date. Im running an i9, with 32 gb ram and a mobile 3080 card. Its most commonly occuring in perform mode when i run a scipt to open a network pane and then i try to close it. However i dont even hve a second monitor hooked up… if there are any tips you can recommend further, i would greatly appreciate it. thanks!

Edit: Im crashing all over the place. When i try to lay down a node. When i try to link a CHOP into a CHOP execture DAT… when i close an external pane… Is this a driver issue? im on 516.59… does anyone have a known working Nvidia GPU driver on for TD build 2022.25370?

I’ve been messing with 2022.25370 on my Asus laptop with an external 3080 GPU and running Nvidia 516.59 with no issues - and I even still unfortunately have to keep Auroumuouruy Crate installed since I need it to connect / disconnect the external GPU.

You might need to re-install the NVidia drivers with “clean install” checked… possibly also TouchDesigner… possibly also Windows :frowning:

Does this happen when you open a clean / empty TD file and try it? Regardless if stuff is crashing that much, it sounds like something is corrupted (toe file, TD itself, GPU driver, Windows) or even worse could be defective / dying hardware since some GPU problems won’t surface until the GPU is running under heavy load (heat / thermal expansion or just usage of more GPU memory / processing)

Probably not an inherent TD / 516.59 incompatibility issue since MANY more people would be posting issues if that were the case…

Hey @stev_fun

What kind of crash do you get ? Does it give you a specific message ?

Do you get a .dmp file ?


@stev_fun Another user reported instability after updating to 516.59, I wonder if your system is behaving similar. They rolled back to Nvidia 512.95.