Touchdesigner freezes when choosing Player Index - Kinect Azure

Hello, I have a problem with the TOP Kinect Azure and TOP Kinect Azure Select. My firmware is updated and all other options of Image work(Color, Depth, Ir, Point Cloud), but when I choose Player Index. The program freezes completely.

I have a good PC, intel i9, RTX 3090, etc. Do you know what can be the problem? Thanks.

Solved until today I share the answer from Derivative.

Sorry you’re having problems. I believe the issue is with the body tracking AI used in the Player Index mode and your RTX card. If you check out this thread on the Microsoft Azure github, there are a lot of people with 30XX generation cards having problems: https://github.com/microsoft/Azure-Kinect-Sensor-SDK/issues/1125

Microsoft originally said they were going to release an update last October/November to address this, but unfortunately that never happened. According to the last post in the thread, they’re now saying middle of next month (february I guess). Once Microsoft’s update is out, we’ll have to update TouchDesigner to the new version, but that shouldn’t take very long.

cheers,

1 Like

Thanks for following up @cardelluis, we’ll update this thread once there is a fix from Microsoft available as well.

2 Likes

Hi. Are there any news on this? I am delivering a project with 4 interactive screens with 2 Azure connected in a row and kinect data just freezes from time to time or when I switch cooking on some containers from the project. Specs are rtx 2080 // intel i9 // Touch build from May.
I do not want to use the latest build because it has a problem with Touchplayer (it says invalid window format) and it won’t just do for an autoplay set-up.

You’re issue is unrelated to the original posters report, this problem is only with 30-series Nvidia GPUs.
Have you tried using the most up to date 2020 build? We recommend using 2020.28110 which has months of improvements over the May build, including a number of Kinect Azure updates. It also does not have the TouchPlayer issue you refer to in 2021 (which will be fixed in the next build we post btw).
If you switch to using 2020.28110 and it still crashes (seems stable here) please send us a dump file.

1 Like