TouchDesigner refuses to start

I have a Windows 10 PC with Nvidia RTX2080 GPU which in every respect appears to be working 100% fine… But it will not launch TouchDesigner 099. The application appears to start (icon appears briefly in task bar) and then just exits within a second or less. No error messages, nothing.

I have tried uninstalling/reinstalling TouchDesigner, upgrading Nvidia drivers. I even tried installing an older version of TouchDesigner from a few months ago… no difference at all.

Any ideas what I can try next?

A curious update… TouchDesigner 088 does work on the same PC.

Of course I don’t want v088… I want v099.

What on earth could be causing this behaviour?

Does the machine have any bloatware on it from the manufacturer? This is the most common cause for this issue.

Well unless you count Windows itself, no :wink:

It’s a desktop machine, so there is very little in the way of bloatware that I can see.

What sorts of applications precisely did you have in mind?

Stuff from MSI and Alienware, so nothing you’d have. Can you check the Windows event log to see if there are any messages in there?

No messages relevant to TouchDesigner other than notes about when it was installed or uninstalled

Thanks, I’ve just written an article to help diagnose this issue further, can you follow the instructions there and we should be able to get to the bottom of this:
https://docs.derivative.ca/Using_WinDbg_to_Debug_Startup_Failures

Thanks for the help so far. I was on leave for a few days, but going to try this out and report back what I find!

Hi @RandomStudio01, did you have any luck getting TD going?