TouchDesigner runs background process but won't launch

When I click touch designer, it just does nothing. I can open task manager and see it running in the background, but it never launches. I’m running it on an asus laptop with windows 11. I have the most recent graphics drivers, I’ve uninstalled and reinstalled it, I’ve run it on compatibility mode. Please help!

Hi @mbowman,
Another user reported something similar and needed to use the “run compatibility troubleshooter” and it fixed the issue. Reported here FIXED: Can't open touchdesigner. Only run in background

Can you give that a try and report back to us?

I tried it, as well as changing the compatibility to different windows processors manually, and neither one changed anything unfortunately

We’ll need more information about your system as we can’t replicate the issue here.

What version of TouchDesigner are you opening? Please try 2022.32120

What graphics drivers specifically are you using? More importantly where they are updated from. Using Windows updates for graphic drivers will not work, you must get the latest from Intel, AMD, or Nvidia depending on the GPU you have.

Laptops almost always have bloatware that could interfere with the proper operation of programs. Searching for “bloatware” on this forum will give you many reports or things to uninstall. I personally always wipe new Windows laptop when receiving them and resin tall fresh Windows to get rid of this unfortunate situation.

I am running the non-commercial form of touchdesigner 2022.32120.

I’ll list below my system information, but I will also look into bloatware, so thank you so much taking time to help me! I appreciate it.

My device:
Processor: AMD Ryzen 7 4800H with Radeon Graphics 2.90 GHz
Installed RAM: 16.0 GB (15.4 GB usable)
System type: 64-bit operating system, x64-based processor

My system:
Edition: Windows 11 Home
Version: 22H2
Installed on ‎2/‎12/‎2023
OS build 22621.1265
Experience Windows Feature Experience Pack 1000.22638.1000.0

My graphics card and drivers:
NVIDIA GeForce GTX 1660 Ti

GeForce Game Ready Driver
Version: 528.49
I just updated it on the 8th of this month.

Hopefully this is the right information? I just included everything I could think of.

I have the exact same problem. If I double click on it let’s say 3 times it opens it in the background 3 times too but never launch. I also use the free version.

My device:
ASUS TUF Gaming A15 laptop
Processor: AMD Ryzen 9 4900H with Radeon Graphics 3.30 GHz
RAM: 32,0 GB
System type: 64-bit operating system, x64-based processor

My system:
Windows 11 Pro
Version: 22H2
Installed: ‎2022. ‎12. ‎23.
OS build: 22621.1265

My graphics card and drivers:
NVIDIA GeForce GTX 1660 Ti
with NVIDIA Studio Driver

Thanks in advance!

1 Like

I’ve tried stripping away bloatware programs and still haven’t had any luck. Is there anything else you recommend?

I’m also hitting this issue with 2022.32120 on a Windows 10 Asus laptop, pretty stripped of bloatware.

2047MB NVIDIA GeForce RTX 2060 with latest studio drivers

Incidentally, I can run TD 2021.13610 from an older install on this laptop

EDIT: I’ve tried the compatability fix posted above with no fix.
I can also run TD 2022.32120 on my desktop with a 3080

Hey everyone,

Is your machine a laptop @mbowman ? Asus ?

Can Asus owners look for Nahimic in their system? It’s advertised as an audio driver if I am correct, but notorious for causing issues and shipping with some Asus laptops.

If you find it, please remove / uninstall and let us know.

Additionally, for @mbowman - I see you have a combo of AMD Integrated graphics and Nvidia GPU, can you follow this and let us know if that helps: Unable to launch Vulkan apps/game on notebooks with AMD Radeon iGPUs | NVIDIA


Nothing with Nahimic in the name on my machine.

I’ve also tried switching to the latest Nvidia Game Ready driver as opposed to Studio drivers but no luck.

I can confirm that the Radeon update worked for me. Thank you!

1 Like

@e.roche230 You also had an AMD CPU with Integrated graphics on your machine ?

Could you try updating the AMD drivers on your machine as well? (Radeon drivers are for AMD GPUs)
It seems these systems with AMD CPU and integrated GPU might be having their issues with the integrated GPU from AMD getting in the way.

Yep! Updating the AMD drivers fixed the issue

1 Like

Hello! I still have the same issue, I did update my nvidia studio and AMD driver and there’s no Nahimic in my system. :frowning_face:

Hey @Reenglo

Your machine is also a mix of AMD integrated graphics and Nvidia, did you try following this procedure here: Unable to launch Vulkan apps/game on notebooks with AMD Radeon iGPUs | NVIDIA



Hey I had the same issue as the one mentioned above and found another solution as none of these worked for me.

AMD Ryzen 7 4800H with Radeon Graphics 2.90 GHz
Nvidia RTX 2600
16 gb Ram

I followed this guide i found online for manually changing the gpu used by a program on windows 10

  1. Open Settings on Windows 10.
  2. Click on System.
  3. Click on Display.
  4. Under the “Multiple displays” section, click the Graphics settings option.
  5. Click Browse and then find the .exe file for TouchDesigner and TouchPlayer. I updated all of them to only use my Nvidia GPU and now it runs the latest version without any issues!

I hope this helps