UI Interface Text Not Shown in Mac TouchDesigner

I’ve tried installing and running the latest TouchDesigner for Mac, and the UI interface is not showing any interface text. (See the screenshots)

Has anyone encountered this? And solved it?


Computer: Mac Intel, MacBook Pro
OS: MacOS Ventura 13.6.3
TouchDesigner: Mac, Intel version 2023.11510

Official is currently ahead of experimental builds. Please install TD official and try again.

Looking more closely, your window says experimental but that is an official build number. Very strange. Will look into it.

Please try deleting your font cache as mentioned in this thread

Let us know if that works for you, thanks!

Hi @ben and @Ivan , thanks for those responses. @ben , where do I type that line that you gave me (to delete my font cache), inside of MacOS Terminal?

@jlui1200 yes, inside of MacOS Terminal.

I’m having the same problem, with 2023.11510 and even after deleting the font-cache, no fonts are showing up.

I’ve also tried going back to 2022.35320 (deleting the font-cache first) and that doesnt seem to work either. I thought that it might be the OS, so I’ve tried bumping to sonoma, but no joy either.

The list of fonts that end up in the FontCache seems small -
-rw-r–r-- 1 sam staff 267532 Mar 3 18:49 Apple Color Emoji.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 525560 Mar 3 18:49 EuphemiaCAS.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 554056 Mar 3 18:49 Galvji.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 658240 Mar 3 18:49 GeezaPro.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 291784 Mar 3 18:49 Kailasa.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 602480 Mar 3 18:49 Kefa.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 321988 Mar 3 18:49 Kohinoor.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 297532 Mar 3 18:49 KohinoorBangla.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 113092 Mar 3 18:49 KohinoorGujarati.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 301060 Mar 3 18:49 KohinoorTelugu.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 808388 Mar 3 18:49 LucidaGrande.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 207992 Mar 3 18:49 Malayalam Sangam MN.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 3500032 Mar 3 18:49 MaterialDesignIconsDesktop.ttf.0000000065e49265.02.slug
-rw-r–r-- 1 sam staff 1092580 Mar 3 18:49 Menlo.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 419156 Mar 3 18:49 MuktaMahee.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 263264 Mar 3 18:49 NotoNastaliq.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 118908 Mar 3 18:49 NotoSansKannada.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 190144 Mar 3 18:49 NotoSansMyanmar.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 94260 Mar 3 18:49 NotoSansOriya.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 425892 Mar 3 18:49 OpenSans-Bold.ttf.0000000065e49265.02.slug
-rw-r–r-- 1 sam staff 432480 Mar 3 18:49 OpenSans-Regular.ttf.0000000065e49265.02.slug
-rw-r–r-- 1 sam staff 203336 Mar 3 18:49 Sinhala Sangam MN.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 470432 Mar 3 18:49 Thonburi.ttc.0000000065bd2423.02.slug
-rw-r–r-- 1 sam staff 81964 Mar 3 18:49 TouchDesigner.ttf.dc9c5bbe68fb58ec76789ff301e24120.02.slug

Sam.

I found that I had quite a few fonts in my “Users” font book (Open OSX Font Book) and select My Fonts, including duplicates of what should otherwise be system fonts like veranda. I disabled the veranda ones, AND deleted the font cache (as above), and that cleared it up.

I think what is happening is if you import settings from an old mac, its copying over all the old fonts, so you are accumulating old potentially bad fonts.

1 Like

Interesting hypothesis, we are seeing a mess between system fonts and user fonts in a number of cases so we’ll try this suggestion for future cases.