Vulkan errors when instances point cloud

Hi, I have a problem when I make point cloud on a 3d building scanning. The glsl top I used for normalizing the point file in is simple and i don’t know what is wrong with it. Does anyone have the same problem and solved it? Thank you!

Hey @quynhisliving

Can you share a sample file or the GLSL code so that we can try to reproduce it?


Hi @JetXS this is the code from Markus Heckmann’s tutorial. It works perfectly with another point cloud file in. But when I use a building 3d model it starts crashing. Sorry for my bad english.
Thank you!

out vec4 fragColor;
void main()
vec4 posInput = texture(sTD2DInputs[0],;
vec4 minInput = texture(sTD2DInputs[1],;
vec4 maxInput = texture(sTD2DInputs[2],;

//vec4 color = vec4(0.0);
//center everything
vec4 centerOffset = (maxInput - minInput)/2.0 + minInput;
vec4 color =posInput - centerOffset;
//scale everything
vec4 maxBounds= abs(maxInput-minInput);
float maxsize= max(maxBounds.r, maxBounds.g);
maxsize = max(maxBounds.b, maxsize);
color *= 1.0/maxsize;
fragColor = TDOutputSwizzle(color);


There is another problem when I use a 3d model for instancing GEO, it also appears same Vulkan errors. I use Rog Zephyrus GA401 with GTX 1605Ti, AMD Ryzen 7 4800HS.

Hey @quynhisliving

I cannot reproduce on my end at the moment.

Could you please try the simple attached file, and tell me if that triggers a crash or not ?

If no crash, can you progressively increase the resolution of the 3 input TOPs ?

If still no crash, can you try to render the points from Null1 as instances in a Geo COMP? Does it crash now ?

normalizeShaderTest.toe (4.3 KB)

Sorry the forum don’t let beginner upload the link so I cannot send you my sample file.
I need to shift the whole structure into the center coordinates system, so the second and third input of GLSL will be minimum and maximum extend of normal, to find out how much to scale and shift the object.
You can recreate it and connect with any point filein to instances in GEO.
Thank you!

I have a same problem, but It happen when I close a component .
This is happen even in blank project, for example when I close OP snippets!

@quynhisliving There is this tip for people using Nvidia/AMD systems

Its for apps not launching, so maybe not your case here but I thought I’d put it here incase it helps you or others.

Thank you. I updated my GeForce and AMD drivers but it keeps happening even when I just add Environment Map or connect Chop data to SOP (such as Lsystem). Hope it will be fixed soon.