WebRender TOP and scroll bars

Hi all, is there a way to disable the scrollbars in the WebRender TOP?
I don’t mind if contents are outside viewable area, I just want a “clean” render.
Thank you!

Does the CSS overflow:hidden work in your case?
https://www.w3schools.com/css/css_overflow.asp

There is an CLI argument --hide-scrollbars and I thought it could be passed in via the options-parameter, but this seems to be wrong :frowning:
So yeah, interrested in that myself!

Would interested in a solution as well.

Hi, I tried it bjut it seems it crasches the TOP :open_mouth: and let TD close.
Just testing to understand what happens.
Thank you!

Found 2 options for you. So the first one turns off scrollbars for the page you’ve loaded. Works with the Derivative site at least

op('webrender1').executeJavaScript('document.body.style.overflow="hidden"')

The second, probably better option, is to use this in the Options parameter of the Web Render TOP. Puts on an overlay scrollbar that only appears when you are scrolling. Of course, no guarantees it’ll keep working next time we update cef/chromium.

--enable-features=OverlayScrollbar

Hope this helps.

Awsome! Any hint btw on where to find the options that ar usable? I tried several cli-arguments but they did not seem to do the trick.

Along the same lines: is there a way to put cef into tablet mode ?

There’s an unofficial list of chromium options here, I’ve added a link to the Web Render TOP wiki page. I see a --force-tablet-mode option. I’m guess you’ll have to experiment a bit to see if there’s anything that might work for you.

https://peter.sh/experiments/chromium-command-line-switches/

Thank you very much all!
At the moment I resolved putting overflow=“hidden” in my CSS.
As soon as possible I will try to use the command line options.